myUVU Students tab errors
Incident Report for Utah Valley University
Resolved
The errors on the Students tab in myUVU have been resolved. Please contact the Service Desk if you experience any more issues.
Posted May 07, 2021 - 15:22 MDT
Monitoring
A fix has been applied and students should no longer encounter errors on the Students tab in myUVU. We will continue to monitor myUVU closely.
Posted May 07, 2021 - 10:56 MDT
Investigating
We are investigating reports that users are encountering errors on the Students tab in myUVU. Updates will be provided as we learn more.
Posted May 07, 2021 - 10:34 MDT
This incident affected: myUVU Services (myUVU Student Services).