Microsoft Account Password Reset Outage

Incident Report for Utah Valley University

Resolved

The outage affecting Microsoft account password reset has been resolved. Please contact the Service Desk if you experience any more issues.
Posted Aug 21, 2025 - 10:34 MDT

Monitoring

A fix has been applied and Microsoft account password reset should be available for all users. We will continue to monitor this closely.
Posted Aug 20, 2025 - 13:30 MDT

Investigating

We are investigating reports of a Microsoft account password reset outage. Updates will be provided as we learn more.
Posted Aug 20, 2025 - 13:13 MDT
This incident affected: General IT Services.