Tims.uvu.edu Outage

Incident Report for Utah Valley University

Resolved

The tims.uvu.edu outage has been resolved. Please contact the Service Desk if you experience any more issues.
Posted Aug 27, 2025 - 13:37 MDT

Monitoring

A fix has been applied and tims.uvu.edu should be available and functioning as expected. We will continue to monitor tims.uvu.edu closely. Please contact the service desk if any issues are encountered.
Posted Aug 26, 2025 - 13:54 MDT

Identified

We have identified degraded performance when accessing tims.uvu.edu. The service is up, however response times may be longer than usual. Updates will be provided as we learn more.
Posted Aug 26, 2025 - 11:03 MDT

Investigating

We are investigating reports of a tims.uvu.edu outage. Updates will be provided as we learn more.
Posted Aug 26, 2025 - 10:00 MDT
This incident affected: Employee and HR Services (TIMS Employee Time Management).