Wasatch Campus Power Outage

Incident Report for Utah Valley University

Resolved

The power outage affecting the UVU Wasatch campus has been resolved. Please contact the Service Desk if you experience any more issues.
Posted Jul 17, 2025 - 14:59 MDT

Monitoring

A fix has been applied and the power outage affecting the UVU Wasatch campus should be resolved. We will continue to monitor the power closely.
Posted Jul 17, 2025 - 11:59 MDT

Identified

We have identified a power outage affecting the UVU Wasatch campus. Updates will be provided as we learn more.
Posted Jul 17, 2025 - 11:02 MDT
This incident affected: Campus Services (Power).