uvu.edu Outage
Incident Report for Utah Valley University
Resolved
The uvu.edu outage affecting all users has been resolved. Please contact the Service Desk if you experience any more issues.
Posted Feb 02, 2024 - 14:17 MST
Monitoring
A fix has been applied and uvu.edu should be available to all users. We will continue to monitor it closely.
Posted Feb 02, 2024 - 10:36 MST
Identified
We have identified a uvu.edu outage affecting all users. Updates will be provided as we learn more.
Posted Feb 02, 2024 - 10:29 MST
This incident affected: General IT Services.