USHE Concurrent Enrollment Participation Form Outage

Incident Report for Utah Valley University

Resolved

The USHE concurrent enrollment participation form outage has been resolved. Please contact the Service Desk if you experience any more issues.
Posted Apr 22, 2026 - 15:10 MDT

Identified

We have identified a third party vendor outage affecting users ability to complete the USHE concurrent enrollment participation form. Updates will be provided as we learn more.
Posted Apr 16, 2026 - 14:05 MDT
This incident affected: Registration and Planning (Class Registration).