Partial myUVU Outage

Incident Report for Utah Valley University

Resolved

The myUVU outage impacting Workplace and Student users has been resolved. Please contact the Service Desk if you experience any more issues.
Posted Jun 02, 2026 - 09:43 MDT

Monitoring

A fix for the loading issue on Workplace and Student pages in myUVU has been applied. The situation is being monitored to ensure continued functionality
Posted Jun 01, 2026 - 15:48 MDT

Investigating

We are investigating reports of Workplace and Student not loading in myUVU. Updates will be provided as we learn more.
Posted Jun 01, 2026 - 08:41 MDT
This incident affected: myUVU Services (myUVU General Services, myUVU Student Services, myUVU Employee Services).