Partial Call Center Outage

Incident Report for Utah Valley University

Resolved

The partial UVU call center outage has been resolved. Please contact the Service Desk if you experience any further issues.
Posted Sep 03, 2025 - 08:36 MDT

Monitoring

A fix has been applied and all call centers at UVU should be functioning normally. We will continue to monitor the call centers closely.
Posted Sep 02, 2025 - 12:29 MDT

Identified

We have identified a partial external call center outage affecting users attempting to reach call centers at UVU. Updates will be provided as we learn more.
Posted Sep 02, 2025 - 11:29 MDT
This incident affected: Email, Calendar, & Collaboration (Telephones).