Partial Microsoft Outlook Outage

Incident Report for Utah Valley University

Resolved

This incident has been resolved.
Posted Aug 25, 2025 - 09:55 MDT

Investigating

We are investigating reports of a Microsoft Outlook outage affecting new faculty members. Updates will be provided as we learn more.
Posted Aug 20, 2025 - 11:31 MDT
This incident affected: Software, Websites & Apps (Office 365).