Dining Services Point-Of-Sale Systems Outage Outage

Incident Report for Utah Valley University

Resolved

The POS outage affecting UVU Dining Services has been resolved. Please contact the Service Desk if you experience any more issues.
Posted Sep 16, 2026 - 12:52 MDT

Monitoring

A fix has been applied and Dining Services POS Systems should be available to users. We will continue to monitor Dining Services Point-Of-Sale systems closely.
Posted Sep 15, 2026 - 15:35 MDT

Investigating

We are investigating reports of POS systems outage for all UVU Dining Services. Updates will be provided as we learn more.
Posted Sep 15, 2026 - 15:19 MDT
This incident affected: Payments and POS Services (Dining and POS Services).