Microsoft Teams User Search Issue

Incident Report for Utah Valley University

Identified

Investigation of this issue by Microsoft is ongoing.

Workaround: Users that are not appearing in Teams may be made searchable by sending an email to their uvu.edu email address, or searching for a customized email address such as firstname.lastname@uvu.edu.
Posted Apr 02, 2025 - 16:36 MDT

Investigating

We are investigating reports of an issue with some users in Microsoft Teams not showing up when searched. Updates will be provided as we learn more.
Posted Mar 26, 2025 - 10:01 MDT
This incident affects: Email, Calendar, & Collaboration (Teams).