Teams Meeting Scheduling Outage

Incident Report for Utah Valley University

Resolved

The Microsoft Teams meetings scheduling outage has been resolved. Please contact the Service Desk if you experience any further issues.
Posted Sep 03, 2025 - 13:12 MDT

Identified

We have identified a partial outage in Microsoft Teams affecting scheduling meetings for classes. A temporary workaround is to use the "Meet Now" button in the General channel for your class in Teams. Please contact the Enterprise Service Desk for further details.
Posted Aug 20, 2025 - 07:58 MDT

Investigating

We are investigating reports of a partial outage regarding faculty attempting to schedule meetings for classes. Updates will be provided as we learn more.
Posted Aug 19, 2025 - 14:36 MDT
This incident affected: Email, Calendar, & Collaboration (Teams).