Partial MyUVU Outage
Incident Report for Utah Valley University
Resolved
The MyUVU outage affecting broken links has been resolved. Please contact the Service Desk if you experience any more issues.
Posted Feb 23, 2024 - 17:12 MST
Identified
We have identified a partial MyUVU outage affecting various links inside of MyUVU causing some pages and services to be unavailable. Updates will be provided as we learn more.
Posted Feb 23, 2024 - 09:15 MST
This incident affected: myUVU Services (myUVU General Services).