Concur Outage
Incident Report for Utah Valley University
Resolved
The Concur outage has been resolved. Please contact the Service Desk if you experience any more issues.
Posted Mar 04, 2024 - 16:17 MST
Monitoring
The vendor has reported all systems as online; Concur should be available to all users. We will continue to monitor Concur closely.
Posted Mar 04, 2024 - 13:54 MST
Identified
We have identified a Concur outage affecting users ability to login and submit reports. Updates will be provided as we learn more.
Posted Mar 04, 2024 - 07:27 MST
This incident affected: General IT Services.