MyUVU Search Function Partial Outage

Incident Report for Utah Valley University

Resolved

The partial outage affecting the myUVU search function has been resolved. Please contact the Service Desk if you experience any more issues.
Posted Aug 19, 2025 - 11:47 MDT

Monitoring

A fix has been applied and the myUVU search function should be working normally. We will continue to monitor the service closely.
Posted Aug 19, 2025 - 08:34 MDT

Identified

Titles may not show correctly when searching within myUVU. Updates will be provided as we learn more.
Posted Aug 18, 2025 - 11:10 MDT

Investigating

We are investigating reports of a partial outage regarding the search function on MyUVU. Updates will be provided as we learn more.
Posted Aug 12, 2025 - 12:49 MDT
This incident affected: myUVU Services (myUVU General Services).