Qualtrics Survey Outage

Incident Report for Utah Valley University

Resolved

The Qualtrics survey outage has been resolved. Please contact the Service Desk if you experience any further issues.
Posted Apr 03, 2025 - 10:34 MDT

Monitoring

Qualtrics surveys should be available for all users. We will continue to monitor Qualtrics surveys closely.
Posted Apr 03, 2025 - 08:54 MDT

Investigating

We are investigating reports of a Qualtrics survey outage. More information will be provided as we learn more.
Posted Apr 02, 2025 - 18:49 MDT
This incident affected: General IT Services.