my.uvu.edu Outage
Incident Report for Utah Valley University
Resolved
The my.uvu.edu outage has been resolved. Please contact the Service Desk if you experience any more issues.
Posted Dec 13, 2023 - 17:45 MST
Monitoring
A fix has been applied and my.uvu.edu should be available. We will continue to monitor it closely.
Posted Dec 13, 2023 - 16:27 MST
Identified
We have identified a my.uvu.edu outage. Updates will be provided as we learn more.
Posted Dec 13, 2023 - 15:56 MST
Monitoring
A fix has been applied and my.uvu.edu should be available to all users. We will continue to monitor it closely.
Posted Dec 13, 2023 - 15:30 MST
Investigating
We are investigating reports of a my.uvu.edu outage. Updates will be provided as we learn more.
Posted Dec 13, 2023 - 15:19 MST
This incident affected: myUVU Services (myUVU General Services, myUVU Student Services, myUVU Employee Services).