New myUVU Partial Outage
Incident Report for Utah Valley University
Resolved
The new myUVU students website outage has been resolved. Please contact the Service Desk if you experience any more issues.
Posted Feb 29, 2024 - 15:15 MST
Monitoring
The new myUVU students website should be fully functional for both current and former students. We will continue to monitor the website closely.
Posted Feb 29, 2024 - 12:48 MST
Update
Functionality of the new myUVU students website has been restored to current students. Former students are still affected.
Posted Feb 29, 2024 - 11:12 MST
Update
The primary data display issues have been corrected. Further fixes are being implemented for minor errors. Updates will be provided as we learn more.
Posted Feb 29, 2024 - 09:21 MST
Identified
We have identified a partial outage affecting the new myUVU students website causing invalid data to be presented to users. Updates will be provided as we learn more.
Posted Feb 29, 2024 - 08:21 MST
This incident affected: myUVU Services (myUVU Student Services).