Partial Network/Power Outage
Incident Report for Utah Valley University
Resolved
The power outage across campus has been resolved. Please contact the Service Desk if you experience any more issues.
Posted Feb 28, 2024 - 09:58 MST
Monitoring
All power issues have been resolved and power should be stable across campus. We will continue to monitor it closely.
Posted Feb 27, 2024 - 15:41 MST
Update
Buildings across UVU campus are continuing to experience intermittent power outages. Updates will be provided as we learn more.
Posted Feb 27, 2024 - 12:03 MST
Update
Other buildings across UVU campus are experiencing power outages. Updated will be provided as we learn more.
Posted Feb 27, 2024 - 09:01 MST
Identified
We have identified a partial network outage primarily affecting Gunther Trades and the Noorda Center. Updates will be provided as we learn more.
Posted Feb 27, 2024 - 07:55 MST
This incident affected: Network & Wireless (Wireless Network, Wired Network).