MyUVU and uvu.edu Scheduled Maintenance

Scheduled for Sep 19, 10:00 MDT  -  Sep 20, 02:30 MDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Sep 17, 2026 - 13:34 MDT

Scheduled

MyUVU and uvu.edu system maintenance is scheduled for Saturday, September 19, 10:00 AM through Sunday, September 20, 2:30 AM. MyUVU and uvu.edu may be unavailable during this time. Canvas is expected to remain available.
Posted Sep 17, 2026 - 13:29 MDT
This scheduled maintenance affects: myUVU Services (myUVU General Services, myUVU Student Services, myUVU Employee Services) and Software, Websites & Apps (myUVU).