Watermark Course Evaluation System Outage

Incident Report for Utah Valley University

Update

We anticipate all lingering issues to be resolved within the next 24 hours. Updates will continue to be provided as we learn more.
Posted May 23, 2025 - 12:07 MDT

Monitoring

A fix has been implemented by the vendor and we are monitoring the results. The outage has been resolved for most users. Some users may still experience lingering connection issues until the DNS (domain name system) is cleared by their internet service provider or on their individual device. Users can try any of the following options to attempt to access more quickly:

-Trying a different browser
-Clearing cache and trying the same browser
-Rebooting the computer
Posted May 22, 2025 - 15:45 MDT

Identified

We have identified a Watermark course evaluation outage affecting all users. Updates will be provided as we learn more.
Posted May 22, 2025 - 14:10 MDT
This incident affects: General IT Services.