Degraded Canvas Performance
Incident Report for Utah Valley University
Resolved
Instructure has confirmed that this is an issue with Comcast Xfinity. If you are still getting error messages, please report this behavior to your internet service provider.
Posted Mar 05, 2024 - 14:54 MST
Investigating
Instructure is investigating degraded performance of Canvas affecting users of Comcast Xfinity as their internet service provider. Updates will be provided as we learn more.
Posted Mar 05, 2024 - 14:31 MST
This incident affected: Teaching, Learning, & Classrooms (Canvas).