MyUVU Student Outage
Incident Report for Utah Valley University
Resolved
The myUVU Student outage has been resolved. Please contact the Service Desk if you experience any more issues.
Posted Apr 10, 2024 - 08:22 MDT
Monitoring
A fix has been applied and MyUVU Student should be available for all users. We will continue to monitor it closely.
Posted Apr 09, 2024 - 18:08 MDT
Update
We are continuing to investigate this issue.
Posted Apr 09, 2024 - 18:01 MDT
Investigating
We are investigating reports of a MyUVU Student outage. Updates will be provided as we learn more.
Posted Apr 09, 2024 - 17:49 MDT
This incident affected: myUVU Services (myUVU General Services, myUVU Student Services, myUVU Employee Services).