UVU online campus map outage

Incident Report for Utah Valley University

Resolved

The UVU campus maps outage has been resolved. Please contact the Service Desk if you experience any more issues.
Posted Aug 20, 2025 - 15:12 MDT

Monitoring

The 3rd party issue preventing UVU maps from loading has been resolved, and UVU maps should be available to all users. We will continue to monitor UVU map availability closely.
Posted Aug 20, 2025 - 08:28 MDT

Identified

We have identified a UVU online campus map outage related to the underlying 3rd party service. Updates will be provided as we learn more.
Posted Aug 20, 2025 - 08:15 MDT

Investigating

We are investigating reports of a UVU online campus map outage. Updates will be provided as we learn more.
Posted Aug 20, 2025 - 07:45 MDT
This incident affected: myUVU Services (myUVU General Services).